RouterOS на DigitalOcean

Очень часто, облачные провайдеры дают возможность ставить только определённую ОС из списка. Однако если постараться, то можно получить инстанс с нужной нам операционной системой. Например вот так, одной командой, можно установить RouterOS на сервер у DigitalOcean:

# wget https://download2.mikrotik.com/routeros/6.38.7/chr-6.38.7.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=33554944 chr.img /mnt && \
ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip service disable telnet
/user set 0 name=root password=MySuperPa55word
 " > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/vda && \
echo "sync disk" && \
echo s > /proc/sysrq-trigger && \
echo "Sleep 5 seconds..." && \
sleep 5 && \
echo "Reboot now..." && \
echo b > /proc/sysrq-trigger

Выполнять команду нужно из уже установленной на виртуальный сервер ОС (Я ставил из CentOS 7). Две минуты, и вот у нас уже установлен свой роутер в облаке. Доступ на него можно получить по SSH, с паролем MySuperPa55word.

@SysadminNotes | https://sysadmin.pm

5 thoughts on “RouterOS на DigitalOcean

  1. А можно пример, для чего может понадобиться роутер на VDS\VPS? Спасибо!

    1. Распространены случаи использования виртуального роутера (pfSense, Mikrotik CHR) для маршрутизации сетевого трафика и выставления наружу сервисов (NAT) из частной сети в облачной инфраструктуре провайдера

      1. Понятно, просто я для этого использую домашний Микротик. А на VPS только OpenVPN

    2. Установив RouterOS мы получаем готовый к работе маршрутизатор с функциями VPN’а, брандмауэра, QoS для обработки трафика и т. п. Соответствующие задачи и решаются с его помощью. Используется такой маршрутизатор, например, в построении сетей между офисами в разных точках мира.

      1. Именно. У нас, например, iPSec-туннель поднят до наших площадок

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *